Stampa

Canon Pixma 495 su Ubuntu 14.04

Canon Pixma MP495

Di recente ho reinstallato il sistema operativo, aggiornandolo a Ubuntu 14.04 (LTS). Dato che non ho mai avuto un buon rapporto con le stampanti, non ho installato da subito la mia Canon, ma ho (da bravo scemo) aspettato che mi servisse prima di farlo.

Come mi aspettavo, non è stato semplice, ma nemmeno così complesso (ho dovuto fare di molto peggio con una Brother, o con una Kyocera). Spero che questa guida possa essere d'aiuto a chi, come me, possiede questa stampante, oppure a chi ha problemi di questo genere.

Le stampanti Canon sono sono viste benissimo nel mondo Linux, per la loro scarsa compatibilità, ma devo dire che io mi sono sempre trovato bene (sarà questione di culo... che ne so...). Prima avevo una MP450, che sfortunatamente si è rotta. Mio padre ha così comprato una Epson Stylus (non ricordo il modello) a 30€ da MediaWorld. L'acquisto peggiore che mai potessimo fare. Compatibilità con Linux: ottima. Funziona da subito. Qualità di stampa: schifosa. Qualità di scannerizzazione: schifosa. Lo scanner è durato tre mesi poi si è rotto (faceva delle righe nere), mentre la stampante è durata 5 mesi poi si è rotta pure quella.

Fortunatamente, l'incaricato dell'acquisto della nuova stampante fui io, che scelsi questa bellezza al costo da 50€, attirato dal fatto che avesse anche il WiFi: ma non il WiFi schifoso delle HP di quel tempo, che creava una nuova rete a cui connettersi (roba fuori dalla grazia di Dio). La mia bella stampantina (come è giusto che sia) si connette alla rete già esistente ed è possibile usarla anche a distanze chilometriche da essa.

Fatto sta che però la cosa dei driver non è poi così sbagliata... Non è stato facile configurarla con Linux (ho dovuto appoggiarmi ad un sistema Windows), ma una volta configurata sei apposto (inoltre c'è il WPS). Tra l'altro se la si collega via USB i driver vengono aggiunti automaticamente.

La ricerca dei driver nel sito Italiano di Canon non va a buon fine. Nemmeno da quello statunitense. Ma prima di perdere le speranze, dopo una breve ricerca su Google, sono arrivato a questa fantastica pagina di Canon Europa: MP495 Canon Europe dalla quale, come potete vedere, è possibile scaricare il driver della stampante per Debian/Ubuntu (deb) e per Fedora (rpm). Quando tentiamo di installarlo, però, ci avvisa che manca il pacchetto libtiff4, che non è più disponibile da Ubuntu 13.10!

Per i successivi passi, è necessaria una minima conoscenza del Terminale.

Inutile girarci troppo attorno, farsi paranoie mentali su sicurezza di installare un pacchetto fuori dai repository, eccetera. Andiamo sulla pagina del pacchetto e scarichiamocelo! Dentro la pagina dovete scegliere l'architettura (i386 oppure amd64) e poi il mirror dal quale scaricarlo (se non sapete cosa mettere scegliete a caso, il pacchetto pesa solo 150kB).

Per installare il tutto, una volta che avete scaricato il pacchetto:

sudo dpkg -i libtiff4_XXXXXXX

(completate il nome del file con il tasto TAB) e poi, spostandovi nella cartella decompressa scaricata dal sito della Canon:

sudo ./install

Et voila! Una volta completata la procedura via terminale (molto semplice) avrete la vostra stampante funzionante!

Ho trovato anche una pagina dove vanno a modificare anche la risoluzione di stampa e di scannerizzazione, non l'ho mai testato (non ne ho mai sentito la necessità), ma può essere utile a qualcuno. Tra l'altro anche loro hanno avuto problemi di reperibilità dei driver Canon, e sono andati a pescarli nel sito Australiano.

In caso in futuro vengano rimossi i pacchetti dai vari siti, sarà mia premura fornire il download da questo sito. In caso contrario, preferisco rimandare all'originale.

Aggiungi commento


Codice di sicurezza
Aggiorna